Learn on Demand
UAMS.edu

Support

Technical Support

For technical support issues click here.

Website Viewing Requirements

Internet Explorer 7.0 or later
Mozilla Firefox 25.0 or later
Google Chrome 30.0 or later
Safari 5.0 or later

Educational Content Viewing Requirements

When attempting to participate in an activity, please review the system requirements included on activity overview page.

Internet Explorer 7.0 or later
Mozilla Firefox 25.0 or later
Google Chrome 30.0 or later
Safari 5.0 or later
Adobe Acrobat Reader
Flash Player Plug-In (9.0 or later)
Sound Card & Speakers